Изменение реквизита документа “Акт сверки”

Добрый день!

Подскажите, пожалуйста, возможно ли каким-нибудь штатным способом заменить реквизит “Представление” в документе “Акт сверки расчетов”? Нам необходимо, чтобы в документе по определенному договору подставлялось определенное представление по услугам (то есть, вместо слово “Продажа”, например, стояло слово “Роялти”)? При этом по другим договорам, представление не менялось, так и осталось “Продажи” для товаров.
Речь идет как о печатной форме, так и о xml файле, так как с контрагентами используется ЭДО.

Заранее большое спасибо!

Алина.


Оцените, пожалуйста, данный вопрос:
1 Звезда2 Звезды3 Звезды4 Звезды5 Звезд (Пока оценок нет)
Загрузка...

02 1 01 00 3



Размещено пользователем:
Author

goncharovag63

Все комментарии (8)
  • Avatar

    goncharovag63 Авг 4 2017 - 14:46

    Добрый день!
    Ирина, забыла указать, что работаем в программе Бухгалтерия 3.0.
    Попыталась выполнить алгоритм, выдал ошибку {5:33} ожидается выражение.
    Я правильно понимаю, что это из-за того, что база доработанная?

    • Avatar

      Ирина Шаврова Profbuh8.ru Авг 7 2017 - 09:35

      Не могу сказать, не видя базы. То, что конфигурация доработана – это существенно.
      Я делала на типовом варианете, там все проходит нормально.
      У вас может быть ошибка из-за изменения реквизита в документе или вы неправильно скопировали запрос, что я предложила. Судя по всему, ошибка синтаксическая – в запросе. Но без базы сказать наверняка не получится никак.

      Обратите внимание, что строка “Представление = СтрЗаменить(стр.Представление, “Реализация (акты, накладные)”, “Роялти”);” – это одна строка. Здесь просто не хватает места и “Роялти”);” переносится. Хотя и с переносом все должно работать нормально…

  • Avatar

    Ирина Шаврова Profbuh8.ru Авг 3 2017 - 09:58

    Добрый день!
    Вы работаете в Бухгалтерия 3.0? Странно, что Вы пишите в Представлении о “Продаже”, а не о “Реализация (акты, накладные)”.

    Я буду исходить из того, что работаете Вы в Бухгалтерии 3.0, потому что консультируем мы именно по ней.
    Тогда предложить можно такой способ.

    Через обработку Группового изменения реквизитов.
    Находится она в разделе Администрирование – Поддержка и обслуживание – Корректировка данных – Групповое изменение реквизитов.

    1. Открываете обработку. Выбираете в поле “Выбор элементов для изменения”: Акт сверки расчетов с контрагентом
    2. В ссылке Все элементы задаете отбор по дате и нужному договору

    Прикреплён файл 3

    • Avatar

      Ирина Шаврова Profbuh8.ru Авг 3 2017 - 09:59

      3. Теперь по кнопке [Выполнить алгоритм произвольной формы] вставляете пргограммный код, который я написала:

      // Доступные переменные:
      // Объект – обрабатываемый объект

      Для каждого стр из Объект.ПоДаннымОрганизации Цикл
      Если СтрНайти(стр.Представление, “Реализация”) > 0 Тогда
      Представление = СтрЗаменить(стр.Представление, “Реализация (акты, накладные)”, “Роялти”);
      стр.Представление = Представление;
      КонецЕсли;
      КонецЦикла;

      Для каждого стр из Объект.ПоДаннымКонтрагента Цикл
      Если СтрНайти(стр.Представление, “Реализация”) > 0 Тогда
      Сообщить(“Замена в ” + стр.Представление + ” на ” + “Роялти”);
      Представление = СтрЗаменить(стр.Представление, “Реализация (акты, накладные)”, “Роялти”);
      стр.Представление = Представление;
      КонецЕсли;
      КонецЦикла;

      Объект.Записать(РежимЗаписиДокумента.Проведение);

      Прикреплён файл 00

    • Avatar

      Ирина Шаврова Profbuh8.ru Авг 3 2017 - 10:02

      4. После этого нажимаете на кнопку [Выполнить].
      Должно выйти сообщение об успешной замене

      PS: Обратите внимание, что для Бухгалтерия 3.0 типовое Представление заполняется не текстом “Продажа”, а “Реализация (акты, накладные)”. Если у Вас не так, то, вероятно, у Вас не типовая Бухгалтерия 3.0. Если конфигурация 3.0, пусть и доработанная, то применять этот спосрб можно, только вместо “Реализация….” вставить то, что у Вас требует замены.
      Если не 3.0 – этот способ не подойдет.

      Прикреплён файл 01

    • Avatar

      Ирина Шаврова Profbuh8.ru Авг 3 2017 - 10:03

      Вот результат замены по вкладке “По данным организации”

      Прикреплён файл 1

    • Avatar

      Ирина Шаврова Profbuh8.ru Авг 3 2017 - 10:04

      Вот результат замены в таблице “По данным контрагента”

      Прикреплён файл 02

    • Avatar

      Ирина Шаврова Profbuh8.ru Авг 3 2017 - 10:06

      Можете попробовать на копии базы данных.
      Эти данные отразятся и в печатной форме и в электронном документообороте.

      Но по хорошему, конечно, тут нужна внешняя обработка с очень простым кодом, я его привела, для автоматической замены данных в полях “Представление” по вкладкам “По данным организации” и “По данным контрагента”.

×
Зарегистрируйтесь и получите бесплатно более 200 видеоуроков
по работе в 1С:Бухгалтерия 8, 1С:ЗУП 8, 1С:УТ 8

Пароль будет направлен Вам на E-mail, который Вы укажете

Отправляя эту форму, Вы соглашаетесь с Политикой конфиденциальности и даете
согласие на обработку персональных данных